LIFF SDK older versions to be restricted, requiring update to v2.31.1 or later

Older LIFF SDK versions face planned usage restrictions due to vulnerabilities, requiring an update to v2.31.1 or later.

Required action

If you are using LIFF v2.29.0, update promptly to LIFF v2.31.1 or later.

Changes

  • Usage restrictions for LIFF SDK v2.20.0 to v2.31.0 are scheduled around November 24, 2026.
  • LIFF v2.29.0 is deprecated due to a defect that may have security implications.
  • LIFF v2.29.0 changed internal behavior without altering functionality.

Affected areas

@line/liff@2.29.0https://static.line-scdn.net/liff/edge/2/sdk.js

Open official page

This summary is independently created by Release Radar and is not an official announcement from the vendor. Please read the official page for accurate details.